Office Manager Dokumentenmanagementsystem

Diese Beschreibung bezieht sich auf eine veraltete Version der DMS-Software. Beachten Sie bitte die Dokumentation der aktuellen Office Manager-Version.


Office Manager 5.0 - Benutzerhandbuch
Dokumentenmanagementsystem

6. DMS-Einrichtung

Stife

Projekte und Auswahllisten*

Wählen Sie im Menü Ansicht - Optionen den Eintrag Auswahllisten. Der Dialog 'Auswahllisten' wird geöffnet.

Auswahllisten

Sie finden hier alle Attribute der Dokumentenverwaltung mit dem Eingabestil 'Auswahlliste' (s.u. Menü Datei – Datenbank – Felder definieren).

Markieren Sie auf der linken Seite das Datenfeld, dessen Liste Sie bearbeiten möchten. Klicken Sie:

Tragen Sie z.B. in der Liste Projekt eindeutige Projektnamen ein, denen die Dokumente zugeordnet werden können. Projekte sind beispielsweise ein Produktname, ein Kundenname, 'Bauvorhaben Potsdamer Platz', usw.


Registrieren von Dokumenttypen*

Wählen Sie im Menü Ansicht - Optionen den Eintrag Dokumenttyp.

Das Fenster 'Registrierte Dokument-Typen‘ wird geöffnet.

Dokumenttypen-Allgemein

Um einen neuen Dokumenttyp zu erstellen, wählen Sie im Menü Dokumenttyp den Eintrag Neu. Klicken Sie auf:

Registerkarte Allgemein

Bezeichnung: Bezeichnung des neuen Dokumenttypen, z.B. Word Dokument, Excel Tabelle, MegaCAD Zeichnung, Brief, Fax.

Grafik: Die Dokumente können in der Tabelle anhand ihrer Grafiken schneller gefunden werden. Wenn Sie keine Grafik auswählen, wird eine Standardgrafik verwendet.

Typ: Für Dokumente, die mit externen Anwendungsprogrammen erstellt werden, wählen Sie die Option Standard-Dokument.

Für die speziellen Internet-Funktionen markieren Sie bitte die Option Internetadresse. Es werden dann keine Dokumentdateien, sondern Internetadressen verwaltet.

Die Option EMail ermöglicht Ihnen die Verwaltung von E-Mails aus Outlook, Outlook Express, Netscape und anderen Mailprogrammen per Drag&Drop.

Für die Office Manager-Textverarbeitung markieren Sie die Option Office Manager Textverarbeitung. Es werden keine externen Dateien verwaltet, die Texte werden mit in der Dokumentdatenbank gespeichert.

DV, Dokument/Vorlage: Ein Dokument ist ein Brief oder eine Zeichnung, eine Vorlage eine Briefschablone oder ein CAD-Zeichnungsbauteil.

Registerkarte Datei

Dokumenttypen-Datei

Dateityp: Endung der Dokumentdateien, wie 'txt', 'doc', 'prt'.

Weitere: Liste mit weiteren Dateitypen, die mit dieser Anwendung bearbeitet werden können.

Standardvorlage: eine Datei, die als Vorlage für neue Dokumente verwendet wird. Diese Standardvorlage ist in der Regel ein leeres Dokument. Viele Windows-Anwendungen benötigen immer eine Vorlagedatei, wenn ein neues Dokument erzeugt wird.

Vorlagen: eine Liste mit Dokumentvorlagen für diesen Dokumenttyp. Definieren Sie z.B. für die Textverarbeitung verschiedene Vorlagen für Briefe, Angebote, Notizen usw.

Dokumente in: Verzeichnis, in dem neue Dokumente gespeichert werden, z.B. G:\Daten\Word.

Das Standard-Verzeichnis für neue Dokumente geben Sie in die Administrator-Optionen ein (Menü Ansicht – Optionen - Admin Einstellungen) Geben Sie das Verzeichnis hier nur an, wenn die Dokumente dieser Anwendung in einem anderen Verzeichnis gespeichert werden sollen.

Registerkarte Anwendung

Dokumenttypen-Anwendung

Anwendungsprogramm steuern:

Wählen Sie Windows-Standard, wenn das Betriebssystem anhand der Dateiendung entscheiden soll, in welchem Programm das Dokument geöffnet wird. Dies entspricht einem Doppelklick auf eine Datei im Windows-Explorer.

Ausgewählte Anwendung: geben Sie den Dateinamen der Anwendung im Feld Programmdatei an. Die Dokumente werden immer mit der hier ausgewählten Anwendung geöffnet.

Benutzerdefinierte Steuerung: hier können Sie genau definieren, wie das Anwendungsprogramm gesteuert werden soll. Sie können für jeden Befehl (Öffnen, Drucken, usw.) eine eigenes Programm auswählen und angeben, ob die Programme mit DDE gesteuert werden sollen.

Programmdatei: Dateiname der Anwendung.

In das Verzeichnis der Anwendung wechseln: Wenn die Option markiert ist, wird das Verzeichnis des Anwendungsprogramms zum aktuellen Verzeichnis gemacht, sobald diese Anwendung startet.

Fenstergröße der Anwendung: wählen Sie Vollbild, wenn das Programm immer maximiert geöffnet werden soll oder Normal, um die aktuelle Programmeinstellung zu verwenden.

Registerkarte Vorschau

Dokumenttypen-Vorschau

Dokumenten-Vorschau: Sie können ein externes Vorschauprogramm wählen, den internen Viewer oder die OLE-Vorschau nutzen. Der interne Office Manager-Viewer kann Grafiken (bmp, jpg, emf, wmf, ico), Adobe Acrobat-Dateien (PDF), Text- und HTML- Dateien, sowie andere Dokumente als OLE-Objekt darstellen. Für die Option "Adobe Acrobat" muss der Acrobat Reader ab Version 4 installiert sein.

Registerkarte Befehle

Beinhaltet Einstellungen für Anwendungsprogramme mit benutzerdefinierter Steuerung.

Dokumewnttypen-Befehle

Befehl: wählen Sie den Befehl (Neu, Öffnen oder Drucken) für den Sie die Parameter einstellen möchten.

Programmdatei: ausführbare Programmdatei des gewählten Befehls.

Immer neue Instanz starten: die Anwendung wird mit jedem Dokument neu gestartet. Markieren Sie diese Option für SDI-Anwendungen (Programme die immer nur ein Dokument öffnen können) oder für Programme, die nicht per DDE gesteuert werden können.

Datei als Parameter: aktivieren Sie diese Option, wenn der Dateiname auch bei DDE-Steuerung als Startparameter übergeben werden soll.

Parameter: zusätzliche Startparameter, die der Anwendung beim Startvorgang übergeben werden.

DDE-Steuerung: aktivieren Sie diese Option, wenn die Anwendung per DDE gesteuert werden soll.

DDE synchronisieren: markieren Sie diese Option, um die DDE-Steuerung zu synchronisieren. Der Office Manager warten dann vor dem Senden weiterer Befehle bis das Anwendungsprogramm den vorherigen Befehl abgearbeitet hat.
Diese Option wirkt sich nur aus, wenn mehrere DDE-Befehle (mehrere Zeilen) gesendet werden. Sie sollten diese Option nur markieren, wenn es ohne Synchronisierung zu Problemen kam.

DDE-Kennung: Kennung des Anwendungsprogramms für die Übermittlung von DDE-Befehlen und das Thema der DDE-Kommunikation. Die DDE-Kennung 'Service' ist oft der Programmdateiname ohne Endung (.exe), lesen Sie auch in der Dokumentation des Anwendungsprogramms nach.

Makro: Die eigentlichen DDE-Befehle zum Öffnen, Drucken oder Erstellen von Dokumenten. Informationen hierzu finden Sie in der Dokumentation des entsprechenden Anwendungsprogramms. Hier können auch die Makro-Variablen und -Funktionen der Office Manager-API verwendet werden.

Registerkarte Erweitert

Zusätzliche benutzerdefinierte Befehle.

Dokumenttypen-Erweitert

Der Office Manager ermöglicht Ihnen neben den Standardbefehlen (Neu, Öffnen, Drucken, ...) auch die Definition von eigenen Befehlen. Sie können so z.B. für Ihr CAD-Programm den Befehl 'Bauteil einfügen' definieren, mit dem ein Bauteil in die bereits geöffnete Zeichnung eingefügt wird.

Für einige Dokumenttypen werden die zusätzlichen Befehle automatisch vom Assistenten erstellt.

Siehe auch: Manuelle MegaCAD-Einrichtung, Makro-Variablen und -Funktionen, Archivierung von CAD-Zeichnungen.

Mausschaltflächen

  Neu erstellt einen neuen Dokumenttypen
  ganz links springt zum ersten Datensatz in der Tabelle
  links springt zum vorherigen Datensatz
  rechts springt zum nächsten Datensatz
  ganz rechts springt zum letzten Datensatz in der Tabelle
  Post speichert die Änderungen
  x verwirft die Änderungen
  Löschen löscht den markierten Dokumenttyp
  Eigenschaften Daten direkt in der Tabelle bearbeiten
  Export Tabelle exportieren
  Hilfe ruft die Online-Hilfe mit weiteren Hinweisen auf
  Direkthilfe Direkthilfe
  Schließen Fenster schließen


* Der Menüpunkt kann vom Administrator verborgen werden
CS nur in der Client/Server-Version verfügbar