Office Manager Dokumentenmanagementsystem

Diese Beschreibung bezieht sich auf eine veraltete Version der DMS-Software. Beachten Sie bitte die Dokumentation der aktuellen Office Manager-Version.


Office Manager 5.0 - Benutzerhandbuch
Dokumentenmanagementsystem

7. DMS-Administration

Admin

Der Administrator

Wozu dient die Administration?

Wenn die Dokumentenverwaltung von mehreren Benutzern eingesetzt wird, sollten einige Programmfunktionen für den "normalen" Anwender gesperrt werden. Sonst besteht beispielsweise die Gefahr, dass ein Dokumenttyp versehentlich gelöscht wird und die zugeordneten Dokumente nicht mehr mit dem DMS geöffnet werden können. Es ist auch sinnvoll, das Einrichten immer von ein und derselben Person durchführen zu lassen, dem Administrator, damit keine doppelten Dokumenttypen definiert werden und Auswahllisten nicht unnötig lang werden. Die gezielte und gute Einrichtung Ihres Office Manager bedeutet bei jeder Suche einen Zeitvorteil.

Mit dem Befehl Administrator im Menü Ansicht - Optionen wird die Administratorebene aktiviert. Ein Zugangs-Passwort können Sie im Menü Ansicht - Optionen- Admin Einstellungen auf der Registerkarte Administrator definieren.

Nutzen Sie auch den Einrichtungs-Assistenten (Menü Ansicht – Optionen – Assistent), er führt Sie Schritt für Schritt durch die wichtigsten Optionen.

Der Administrator im Netzwerk

Wenn Sie das Dokumenten-Management-System im Netzwerk betreiben, kann es schwierig sein, alle Nutzer von administrativen Notwendigkeiten zu überzeugen. Um dem Administrator die Arbeit zu erleichtern, gibt es für ihn Möglichkeiten, bestimmte Programmfunktionen zu sperren (die Funktionen sind dann nur in der Administratorebene sichtbar). Wählen Sie hierzu im Menü Optionen- Admin Einstellungen die Registerkarte Administrator. Nutzen Sie in diesem Dialogfenster auch die Direkthilfe [?], um eine Beschreibung der einzelnen Optionen zu erhalten.


Globale Programmeinstellungen*

Wählen Sie im Menü Ansicht - Optionen den Eintrag Admin Einstellungen. Der Dialog 'Einstellungen' wird geöffnet.

Seite Datenbank

Optionen-Datenbank

Sie können hier das Datenverzeichnis und die Standard-Datenbanken (Archive) einstellen.

Die Verzeichnisse werden auf jedem Rechner in der Registrierdatenbank (unter hkey_local_machine) gespeichert. Alle anderen Optionen sind in der Datei "admin.ini" im Pfad der gemeinsamen Dateien gespeichert.

Gemeinsame Dateien: Verzeichnis für gemeinsam genutzte Dateien, wie z.B. die admin.ini und die Auswahllisten für Projekt oder Gruppe. Klicken Sie auf ..., um das Verzeichnis auszuwählen.

Anwendungsdatenbank: Standard-Datenbanken für Dokumenttypen.
Klicken Sie auf ..., um die Datenbank auszuwählen.

Dokumentdatenbank: Standard-Dokumentenarchiv.
Klicken Sie auf ..., um die Archivdatenbank auszuwählen.

Beim Start die zuletzt geöffneten Datenbanken laden: Wenn diese Option markiert ist, öffnet der Office Manager beim Start die Datenbanken, die der Benutzer zuletzt geöffnet hatte.

Dokumentbearbeitung protokollieren: Markieren Sie diese Option, um alle Aufrufe und Bearbeitungen der Dokumente im DMS zu protokollieren.

Seite Optimieren

Optionen-Optimieren

Einstellungen zur Optimierung der Zugriffs-Geschwindigkeit.

Menüs aktualisieren: Wenn diese Option markiert ist, werden die Menübefehle und Mausschaltflächen bei jedem Wechsel des Dokumentdatensatzes aktualisiert. Hierzu müssen die Daten des zugeordneten Dokumenttypen gelesen werden. Entfernen Sie die Markierung, um die Geschwindigkeit beim Wechsel des Dokumentdatensatzes zu beschleunigen.

Programmsymbole darstellen: zeigt oberhalb der Dokumenttabelle das Symbol (Icon) des zugeordneten Windows-Programms. Das Symbol wird bei jedem Wechsel des Dokumentdatensatzes gelesen. Entfernen Sie die Markierung, um die Geschwindigkeit beim Wechsel des Dokumentdatensatzes zu beschleunigen.

Anzeige der Dokumentanzahl: Wenn Sie dieses Feld markieren, wird die Anzahl der gefundenen Dokumente ermittelt. Das Zählen der Dokumente benötigt zusätzliche Zeit bei der Suche. Verzichten Sie bei großen Datenbanken auf diese Option, um die Suchzeiten zu optimieren.

Projekte vorselektieren: Diese Option beschleunigt die Suchabfragen und verringert den Datenverkehr im Netzwerk. Alle Abfragen beziehen sich immer auf das im Projektnavigator ausgewählte Projekt. Beispielsweise ruft die Funktion Suche alle nur alle Dokumente des gewählten Projektes ab. Ist diese Option nicht markiert, ruft der Office Manager alle Dokumente der gesamten Datenbank ab. Wenn Sie zusätzlich die Option Abfrage 'Alle Projekte' zulassen deaktivieren, kann der Anwender immer nur nach Dokumenten einzelner Projekte suchen. Dies stellt sicher, dass bei großen Datenbeständen das Netzwerk nicht unnötig belastet wird. Der erste Eintrag im Projektnavigator lautet dann nicht mehr '[alle Projekte]' sondern '[ohne Projekt]', mit dessen Auswahl Dokumente ohne Projektzuordnung gesucht werden können.

Tipp: Diese Option ist vor allem bei großen Datenbeständen sinnvoll, wenn die Dokumentdatenbank auf einem SQL-ServerCS gespeichert ist (bei Paradox-Datenbanken ist der Geschwindigkeitsvorteil nur minimal). Sie sollten dann die Option Projekte vorselektieren markieren und darauf achten, dass Abfrage 'Alle Projekte’ zulassen nicht markiert ist. Weisen Sie dem Datenfeld Projekt den Eingabestil 'Nur Auswahl aus strukturierter Liste' zu (s. Menü Datei - Datenbank - Felder definieren), dies vermeidet Schreibfehler. Entfernen Sie das Suchfeld 'Projekt' aus dem Layout, damit nur über den Projektnavigator gesucht wird. (s.u. Menü Ansicht - Anpassen - Layout entwerfen - Primäre Suchfelder)

Großschreibung im Feld Nummer: Nummer immer in Großbuchstaben.

Alle Datensätze in den Speicher laden: Wenn diese Option markiert ist, werden alle Dokumente der aktuellen Suche in den Arbeitsspeicher geladen. Die Suche nach Dokumenten kann dadurch -je nach Computer- beschleunigt, aber auch verlangsamt werden. Es wird mehr Arbeitsspeicher benötig. Diese Option bietet Ihnen auch die Möglichkeit die Dokumente in der Datenbank zu gruppieren und zu sortieren. Siehe auch: Dokumente sortieren.

Seite Volltextindex

Optionen-Volltextindex

Die Dokumentenverwaltung ermöglicht neben der Suche in den einzelnen Attributen auch eine sehr schnelle Abfrage über den Volltextindex. Hier sind die Wörter aus allen Attributen (Projekt, Name, usw.), den Notizfeldern und je nach Einstellung auch der Dokumentinhalte enthalten.

Um eine Suche im Index zu ermöglichen, muss die Option Volltextindex entsprechend ausgewählt sein. Sie können die Mindestlänge der Wörter einstellen, Zahlen ignorieren und die Liste der Stopp-Wörter bearbeiten. Wenn der Index auch über die Dokumentinhalte erstellt wird, können Sie die zu indexierenden Dateitypen und die maximale Dateigröße festlegen.

Wenn Sie die Einstellungen geändert haben, muss der Index neu erstellt werden. Klicken Sie dazu auf den Schalter Index neu erstellen.

Beachten Sie bitte, dass diese Funktion sehr zeitaufwändig ist. Bei großen Datenbanken sollte der Index nachts neu erstellt werden.

Volltextindex: Mit dieser Option legen Sie fest, ob ein Volltextindex erzeugt werden soll. Wählen Sie Kein IndexKein Index, um die Indexierung zu deaktivieren. Index über alle Datenfelder, um nur die Attribute oder Index über alle Datenfelder und Dokumente, um auch die Dokumentinhalte zu indexieren. Beachten Sie bitte, dass die Indexierung der Dokumente sehr zeitaufwändig ist. Im Netzwerkbetrieb sollte das Zusatzprogramm "Office Manager ServerIndexer" eingesetzt werden (s.u. Seite , um nur die Attribute oder Index über alle Datenfelder und Dokumente, um auch die Dokumentinhalte zu indexieren. Beachten Sie bitte, dass die Indexierung der Dokumente sehr zeitaufwändig ist. Im Netzwerkbetrieb sollte das Zusatzprogramm "Office Manager ServerIndexer" eingesetzt werden (s.u. Seite , um nur die Attribute oder Index über alle Datenfelder und Dokumente, um auch die Dokumentinhalte zu indexieren. Beachten Sie bitte, dass die Indexierung der Dokumente sehr zeitaufwändig ist.

ServerIndexer verwenden: der Volltextindex wird vom Zusatzprogramm "ServerIndexer" erstellt.

Wörter mit Zahlen ignorieren: Wenn diese Option markiert ist, werden Wörter mit Zahlen (z.B. "webserver2", "0815") nicht in den Gesamtindex übernommen.

Mindestanzahl der Zeichen je Wort: Geben Sie bitte die Mindestlänge der Wörter ein, die in den Gesamtindex übernommen werden sollen. Wenn Sie eine Mindestlänge von 4 Zeichen eingeben, werden Wörter wie "er", "Sie" und "pro" nicht in den Index übernommen.

Liste der zu ignorierenden Wörter: Häufig gebrauchte Wörter (z.B. will, sollen, er, aber, deshalb, ...), nach denen nicht gesucht wird, sollten auch nicht in den Gesamtindex übernommen werden. Sie würden den Index unnötig belasten. Klicken Sie auf Öffnen, um die Liste Ihren eigenen Anforderungen anzupassen.

Liste der zu indexierenden Dateitypen: enthält die Dateiendungen aller Dokumenttypen, die indexiert werden sollen. Klicken Sie auf Öffnen, um die Liste Ihren eigenen Anforderungen anzupassen. Geben Sie die Dateiendungen bitte mit dem führenden Punkt an (z.B. ".txt").

Nur die ersten MB indexieren: Oft ist es nicht sinnvoll, die gesamten Dokumentinhalte zu indexieren. Es ist zu empfehlen, hier einen Wert von 2 MB anzugeben, um nur die ersten 2 MB der externen Dokumentdateien zu indexieren. Das ist ein guter Kompromiss zwischen Geschwindigkeit und vollständiger Indexierung. Geben Sie 0 MB ein, um immer die gesamte Datei zu indexieren.

Index neu erstellen: löscht den vorhandenen Volltextindex und baut ihn komplett neu auf. Diese Funktion ist erforderlich, wenn Sie die Einstellungen geändert haben.

Seite Dokument

Optionen-Dokument

Dokumentenverzeichnis: Standardverzeichnis, in welchem die Dokumentenverwaltung neue Dateien speichert. Geben Sie das Datenträgerverzeichnis ein, in dem der Office Manager neue Dokumente speichern soll. Sie können die Makro-Variablen (s.a. DMS-Entwicklernetzwerk) verwenden, um die Dokumente beispielsweise in einer projektabhängigen Struktur zu speichern ("G:\Daten\{Doc:Project}\{Doc:ApplName}"). Verwenden Sie die Variable {OS:MyFiles} oder klicken Sie auf ..., um den Ordner "Eigene Dateien" als Dokumentenverzeichnis zu definieren.

Die Vorgabe für das Dokumentverzeichnis stellen Sie normalerweise hier in den Administrator-Einstellungen ein. Sie können darüber hinaus für jeden Dokumenttypen ein eigenes Verzeichnis vorgeben (Menü Ansicht - Optionen - Dokumenttyp - Datei - Dokumente in).

Dateinamen erzeugen: Vorgabe, wie die Dateinamen neuer Dokumente erzeugt werden sollen. Verwenden Sie die Makro-Variablen, um den automatisch erzeugten Dateinamen zu definieren (z.B. "{Doc:DocID}" für die eindeutige Schlüsselnummer). Wenn Sie ein neues Dokument mit dem Office Manager erstellen, wird der Dateiname anhand dieser Vorgaben erzeugt.

Änderungen der Dateinamen zulassen: Wenn diese Option markiert ist, kann der Anwender den Pfad und Dateinamen der Dokumente individuell ändern. Deaktivieren Sie die Option, wenn die Dateien immer Ihren Vorgaben entsprechen sollen.

Vorgabe gilt auch für bestehende DateienCS: Markieren Sie diese Option, um die Einhaltung des automatisch erzeugten Dateinamen auch für bestehende Dateien zu erzwingen. Sobald der Anwender ein für den Dateinamen relevantes Attribut (Projekt usw.) ändert, wird die Dokumentdatei umbenannt bzw. in das neue Verzeichnis verschoben. Die Vorgabe gilt auch für Dateien, die per Drag&Drop importiert werden. Beachten Sie bitte, dass diese Option den Datenverkehr im Netzwerk stark belasten kann.

Dokumentnummer automatisch festlegen: Markieren Sie diese Option, wenn die Nummer neuer Dokumente automatisch erzeugt werden soll.

Änderungen zulassen: Wenn diese Option markiert ist, kann der Anwender die automatisch erzeugte Nummer individuell ändern.

Nummer erzeugen: Vorgabe für die automatische Erzeugung von Dokumentnummern. Nutzen Sie die Makro-Variablen, um die Syntax der Nummer festzulegen. Ein Beispiel finden Sie auf der folgenden Seite.

Scanner-Dokumenttyp: Eingescannte Dokumente werden dem hier gewählten Dokumenttyp zugeordnet. Wählen Sie eine Anwendung aus, die Dateien mit der Endung .bmp und/oder .jpg öffnen kann.

Dokumentnummer erzeugen mit ReadIdentNo

Jedes Dokument besitzt in der Office Manager-Datenbank eine eindeutige Schlüsselnummer (Datenfeld DocID). Eine automatische Erzeugung von Dokumentnummern wird daher i.d.Regel mit dem Datenfeld DocID gelöst. Dadurch ist sichergestellt, dass die Dokumentnummern eindeutig sind, sich also nicht wiederholen.

Wenn Sie jedoch die Eindeutigkeit der Dokumentnummern unabhängig von der Schlüsselnummer sicherstellen möchten, können Sie dies mit den Makro-Variablen lösen.

Sie haben drei Möglichkeiten, Aufzählungsvariablen zu lesen: ReadLnFile liest die erste Zeile aus einer Textdatei, ReadAdminIni liest eine Variable aus der ADMIN.INI und ReadIdentNo liest aus der Datenbanktabelle IDENTNO.

Beispiel 1:

In diesem Beispiel wird mit der Makrovariablen ReadIdentNo die Dokumentnummer aus der Tabelle gelesen. Geben Sie im Eingabefeld Nummer erzeugen "{ReadIdentNo:AktDokNr}" ein.

Wenn Sie nun im Office Manager ein neues Dokument anlegen, wird der aktuelle Wert des Datenfeldes AktDokNr aus der Tabelle gelesen (z.B. "3721") und das neue Dokument mit dieser Nummer "3721" gespeichert. Der Office Manager erhöht den Wert um eins und schreibt "3722" in die Tabelle zurück, das nächste Dokument erhält dann die Nummer "3722".

Beispiel 2:

Die Dokumente sollen innerhalb ihrer Projekte fortlaufend nummeriert werden:

"{ReadIdentNo:{Doc:Project,Main}}"

Seite Überwachen

Optionen-Überwachen

Das Dokumentenmanagementprogramm kann ein Verzeichnis überwachen und die in diesem Verzeichnis neu erstellten Dateien übernehmen.

Beispiel: Sie erstellen mit Ihrer Textverarbeitung ein neues Dokument. Sobald Sie das Dokument im Ordner "Eigene Dateien" speichern, erscheint die Eingabemaske des Office Managers und Sie können die Attribute (Projekt, Name, usw.) eingeben.

Verzeichnis überwachen und neue Dateien importieren: Markieren Sie diese Option, um die Verzeichnis-Überwachung zu aktivieren. Der Office Manager übernimmt dann die Dokumente, die im überwachten Verzeichnis gespeichert werden.

Verzeichnis "Eigene Dateien": Markieren Sie diese Option, um das persönliche Systemverzeichnis "Eigene Dateien" zu überwachen. Diese Option ist empfohlen, da die meisten Anwendungsprogramme die Dateien in diesem Pfad speichern. Unter NT-Systemen ist dieses Systemverzeichnis vom angemeldeten Benutzer abhängig

(z.B. 'C:\Dokumente und Einstellungen\[Loginname]\Eigene Dateien').

Verzeichnis: Oder markieren Sie die Option Verzeichnis und geben das zu überwachende Verzeichnis im Eingabefeld ein. Klicken Sie auf ..., um das Verzeichnis im Dialogfenster auszuwählen. Das überwachte Verzeichnis darf nicht dem Standard-Dokumentverzeichnis entsprechen.

Dateien: Legen Sie fest, ob die neuen Dateien aus dem überwachten Verzeichnis in das Dokumentverzeichnis kopiert werden sollen:

In das Dokumentverzeichnis kopieren: Die neue Dokumentdatei wird in das Standard-Dokumentverzeichnis kopiert und anhand der Vorgaben umbenannt.

In das Dokumentverzeichnis verschieben: Die neue Dokumentdatei wird in das Standard-Dokumentverzeichnis verschoben und anhand der Vorgaben umbenannt.

Im überwachten Verzeichnis belassen: Die neue Dokumentdatei verbleibt ohne Änderung im überwachten Verzeichnis.

Hinweis: Wenn die Dokumentdatei nicht im überwachten Verzeichnis verbleibt, kann folgendes Problem entstehen: Sie arbeiten z.B. mit der Textverarbeitung und speichern eine Datei in das überwachte Verzeichnis. Der Office Manager kommt in den Vordergrund und Sie geben die Attribute (Projekt usw.) ein. Nachdem Sie auf OK geklickt haben, wird die Datei in das Dokumentverzeichnis verschoben, in der Textverarbeitung ist aber immer noch das Dokument im überwachten Verzeichnis geöffnet.

Seite eMail

Optionen-EMail

Sie können E-Mails aus Outlook, Outlook Express, Netscape, Eudora Pro und anderen OLE fähigen Mailprogrammen sehr einfach per Drag&Drop in das Archiv übernehmen.

Legen Sie hier fest, in welchen Datenbankfeldern die E-Mail-Attribute gespeichert werden. Wählen Sie dazu das Datenbankfeld aus der Liste, das Attribute Betreff sollte beispielsweise im Feld Name gespeichert werden.

Von: E-Mail-Adresse des Absenders.

An: E-Mail-Adresse des Empfängers.

Betreff: die Betreffzeile (Subject) der Mail.

X-Mailer: vom Absender verwendetes Mailprogramm.

Mail-Client: das Mailprogramm des Empfängers (Quelle der Drag&Drop-Funktion).

Dateiformat: Format, in dem die E-Mails aus Netscape und Eudora gespeichert werden.

Tipp: wenn das Datenbankfeld "MailAttachIco" (Zeichenkette mit der Feldgröße 1) vorhanden ist, werden E-Mails mit Dateianhang mit der Grafik "Büroklammer" markiert. Siehe auch Felder definieren.

Seite Benutzer

Optionen-Benutzer

Sicheres System: Um ein sicheres System zu erhalten, kann die Anmeldung für Benutzer gesperrt werden, die sich unter Windows nicht mit Ihrem Benutzernamen angemeldet haben. Markieren Sie dieses Feld, um nur den Benutzern die Arbeit mit dem Office Manager zu gestatten, die sich unter Windows angemeldet haben.
Sie verwalten also die Anwender zentral im Windows-Betriebssystem.
Wenn diese Option nicht markiert ist, kann sich jeder Anwender im Office Manager anmelden. Die Benutzernamen sind nicht Passwort-geschützt, neue Anwender werden automatisch hinzugefügt.

Registrierte Benutzer: Liste aller Benutzer, die mit dem Office Manager arbeiten. Neue Benutzer werden automatisch der Liste hinzugefügt.

Seite Administrator*

Wenn Sie den Office Manager im Netzwerk betreiben, ist es oft sinnvoll, verschiedene Programmfunktionen für den normalen Anwender zu sperren.

Optionen-Administrator

Passwort ändert das Administratorpasswort.

Logdatei öffnet die Fehler-Logdatei

Hilfe Programm-Hilfe zu den Administratorfunktionen.

Fehlermeldung: Der hier eingegebene Text wird bei Warnungen und Fehlermeldungen mit angezeigt. Geben Sie z.B. "Bei Fragen wenden Sie sich bitte an den Systemadministrator Werner Müller, Apparat 26" ein.

Geschütze Funktionen (für die Anwender gesperrt)

Datenbank-Operationen: sperrt das Untermenü Datei - Datenbank. Mit diesen Menübefehlen können Datensätze aus anderen Datenbanken importiert, neue Datenbanken erstellt und Datenfelder definiert werden.

Datensätze löschen: verhindert, dass Dokument-Datensätze durch die Benutzer gelöscht werden.

Dokument-Feldstandardwerte: verbirgt den Menüeintrag Dokument-Feldstandardwerte für die Benutzer. Mit diesem Menübefehl werden die Datenbank-Felder für neue Dokumente vorbelegt.

SQL Abfragen: verbirgt den Menüeintrag Suche – SQL Abfrage für die Benutzer. Mit diesem Menübefehl werden SQL-Befehle an die Datenbank gesendet. SQL-Befehle werden für die tägliche Arbeit nicht benötigt, sie bieten jedoch sehr flexible Datenbank-Abfragen.

ACHTUNG Mit SQL-Befehlen können auch Datensätze gelöscht werden, dieser Menüeintrag sollte für die Anwender gesperrt sein!

Layout-Einstellungen: verhindert die Änderungen am Layout, den Menü- und Tabellen- Einstellungen durch den Benutzer.

Optionen-Auswahllisten: die Menüeinträge Optionen - Auswahllisten und Optionen - Assistent werden verborgen. Die Anwender können keine Projekte und Auswahllisten mehr definieren.

Optionen-Dokumenttyp: die Menüeinträge Optionen - Dokumenttyp und Optionen - Assistent werden verborgen. Die Anwender können keine Dokumenttypen und Vorlagen definieren.

Optionen-Admin Einstellungen: verbirgt den Menüeintrag Optionen - Admin Einstellungen für die normalen Benutzer. Die Registerkarte Administrator ist aber in jedem Fall gesperrt, auch wenn dieses Feld nicht markiert ist.

Seite Lizenz

Klicken Sie auf die Schaltfläche Lizenznummer, um den Freigabecode einzugeben.

Optionen-Lizenz

Die DMS-Testversion verwaltet maximal 50 Dokumente. Mit der Online-Registrierung können Sie die Anzahl der möglichen Dokumente kostenlos auf 100 erhöhen oder eine Seriennummer für die uneingeschränkte Vollversion des Office Managers erwerben.

Klicken Sie auf Lizenznummer, um Ihre Version online zu registrieren.


* Der Menüpunkt kann vom Administrator gesperrt werden
CS nur in der Client/Server-Version verfügbar