Office Manager Dokumentenmanagementsystem

Diese Beschreibung bezieht sich auf eine veraltete Version der DMS-Software. Beachten Sie bitte die Dokumentation der aktuellen Office Manager-Version.


Office Manager 5.0 - Benutzerhandbuch
Dokumentenmanagementsystem

5. Archiv- und Datenbankfunktionen

Menü Datei

Neue Datenbank erstellen*

Klicken Sie bitte im Menü Datei - Datenbank auf den Befehl Neu, das Fenster 'Neue Datenbank' wird geöffnet:

Neue Datenbank

Wählen Sie den Typ der neuen Datenbank:

Klicken Sie auf die Schaltfläche Weiter.

 

Wenn Sie mit dem Office Manager Client/Server arbeiten, können Sie jetzt den Treiber für die neue Datenbank auswählen:

Datenbankformat

Klicken Sie auf die Schaltfläche Weiter.

 

SQL-Datenbanksysteme erwarten in der Regel eine Anmeldung der Benutzer. Sie können hier festlegen, wie die Anmeldung erfolgen soll CS:

Archiv-Benutzer

Datenbank-Benutzername:

Keiner: es erfolgt keine Datenbank-Anmeldung. Wählen Sie diese Option nur, wenn Sie sicher sind, dass keine Anmeldung erwartet wird.

Office Manager-Benutzername: beim Öffnen der Datenbank wird der Benutzername verwendet, mit dem sich der Anwender im Office Manager angemeldet hat. In diesem Fall müssen Sie für jeden Anwender ein Benutzerkonto in der Datenbank anlegen.

Konstanter Benutzername: jeder Anwender wird mit dem gleichen Benutzernamen an der Datenbank angemeldet. Legen Sie ein Konto für diesen Benutzernamen in der Datenbank an.

Abfrage (Login) beim Öffnen: bei jedem Öffnen der Datenbank muss der Anwender einen Benutzernamen und Passwort angeben.

Passwort:

Keines: für die Datenbank-Anmeldung ist kein Passwort erforderlich.

Konstantes Passwort: Anmeldung mit dem angegebenen Passwort.

Klicken Sie auf die Schaltfläche Weiter.

 

Geben Sie bitte die Dateinamen für die neue Datenbank ein:

Datenbank-Datei

Archiv-Name (nur Dokumentdatenbank): Bezeichnung des neuen Archives.

Office Manager-Zugriffsdatei: Dateiname der Office Manager-Zugriffsdatei (*.omp).


Für die Anbindung an SQL-Server:

Server CS: Name des SQL-Datenbankservers.

Datenbank CS: Dateiname der SQL-Datenbank. Beachten Sie bitte, dass der Dateiname "aus Sicht" des Servers angegeben werden muss.

Klicken Sie auf die Schaltfläche Weiter. Für den Zugriff auf SQL-Server müssen Sie jetzt mit Hilfe der Datenbanksoftware eine neue, leere Datenbank erstellen und die erforderlichen Benutzerkonten einrichten.

 

Datenbank erstellen:

Fertigstellen

Klicken Sie auf Fertigstellen, um die neue Datenbank zu erzeugen. Der Office Manager erstellt die erforderlichen Tabellen und Daten.

Wenn die Option Datensätze kopieren markiert ist, werden alle Daten aus der momentan geöffneten Datenbank kopiert.

Markieren Sie die Option Datenbank-Login, wenn zum Erstellen der Tabellen besondere Benutzerrechte erforderlich sind.


Datenbank importieren

Diese Funktion importiert Datensätze aus einer anderen Datei in das geöffnete Archiv. Sie können hier auf Datenbanken des Office Managers und andere Paradox oder DBase- Dateien zugreifen. Die Funktion importiert nur Datensätze, es werden keine Dokument-Dateien kopiert.

  1. Wählen Sie im Menü Datei - Datenbank den Befehl Importieren:
    Archiv-Import
  2. Klicken Sie auf die Schaltfläche [...] und wählen Sie die Datei, aus der Sie Datensätze importieren möchten.
  3. Felder zuordnen: Wählen Sie in der rechten Tabellen-Spalte (Quelle) die entsprechenden Felder aus der Liste, um sie den Datenfeldern des Archivs zuzuordnen.
    Die linke Tabellenspalte zeigt alle Datenfelder des Archivs. Wenn Sie dem Feld 'Name' z.B. das Feld 'Bezeichnung' aus der Quelltabelle zuordnen möchten, wählen Sie das Feld 'Bezeichnung' aus der Liste der Feldnamen. Die Felder werden automatisch zugeordnet, wenn die Feldnamen identisch sind.
  4. Klicken Sie auf Importieren, um das Einlesen der Datensätze zu starten.

Datenbank exportieren

Diese Funktion speichert die Dokumentdatensätze in eine Paradox-, DBase-, HTML-, XML-, Excel- oder Textdatei.

  1. Wählen Sie im Menü Datei - Datenbank den Befehl Exportieren:
    Archiv-Export
  2. Markieren Sie den gewünschten Dateityp und geben Sie den Namen der zu erstellenden Datei ein.
  3. Im Optionsfeld Exportbereich kann festgelegt werden, ob alle Datensätze der aktuellen Suche oder nur die markierten exportiert werden sollen.
  4. Klicken Sie auf OK, um die Datei zu erstellen. Wenn die Option Datei anzeigen markiert ist, wird die neue Datei jetzt im zugeordneten Anwendungs-Programm (Excel, Webbrowser, Editor) geöffnet.

Tipp: Sie können diese Funktion auch dazu nutzen, um eine Liste der Dokumente mit dem Webbrowser oder Excel auszudrucken.


Datenbanken synchronisieren

Die Funktion ermöglicht den Abgleich mit zuvor ausgelagerten Daten. Zum Beispiel können Sie die, für eine Geschäftsreise relevanten Daten, auf Ihr Notebook auslagern und nach Ihrer Rückkehr mit den Daten im Firmennetzwerk abgleichen. Bei der Synchronisierung werden die Dokumentdateien und die Datensätze aktualisiert.

Siehe auch: Neue Datenbank erstellen

  1. Stellen Sie bitte sicher, dass die originale Dokumentdatenbank (z.B. im Firmennetzwerk) geöffnet ist. Wählen Sie ggf. im Menü Datei den Eintrag Datenbank öffnen, um das Archiv zu laden. Erstellen Sie eine Suche nach allen Dokumenten oder grenzen Sie die aktuelle Suche so ein, dass nur noch die Dokumente angezeigt werden, die Sie abgleichen möchten (s.u. Dokumente suchen).
  2. Wählen Sie im Menü Datei - Datenbank - den Befehl Synchronisieren.
    Dokumentenarchiv Synchronisieren
  3. Geben Sie den Namen der synchronen Datenbank im Feld synchronisieren mit ein (z.B. auf der Notebook-Festplatte).
  4. Legen Sie die Datenpriorität fest:

    Daten der geöffneten Dokumentdatenbank, wenn die Attribute der geöffneten Datenbank gültig sind. Die synchrone Datenbank wird aktualisiert.

    Daten der Synchrondatenbank, wenn die Attribute der synchronen Datenbank gültig sind. Die originale Datenbank wird aktualisiert.

  5. Wählen Sie die Gültige Dokumentdatei:

    Einzeln fragen: Sie müssen bei jeder Datei auswählen, welche gültig ist. Beachten Sie bitte, dass diese Option bei großen Datenbanken sehr zeitaufwendig sein kann.

    Die neuere Datei: Die Dateien mit dem neueren Bearbeitungsdatum sind gültig. Die älteren Dateien werden überschrieben.

    Datei der geöffneten Dokumentdatenbank: Die originalen Dateien (z.B. im Firmennetzwerk) sind immer gültig. Die ausgelagerten werden überschrieben.

    Datei der Synchrondatenbank: Die ausgelagerten Dateien (z.B. auf dem Notebook) sind gültig. Die originalen werden überschrieben.

    Die Dateien werden nur abgeglichen, wenn das Datum oder die Zeit der letzten Bearbeitung unterschiedlich ist.

    Wenn eine Datei nicht existiert, wird die bestehende kopiert (z.B. wird die ausgelagerte Datei immer kopiert, falls die ursprüngliche nicht mehr existiert).

    Legen Sie die Dateipriorität sehr sorgfältig fest und markieren Sie die Option Sicherungskopien erstellen, um Datenverluste zu vermeiden.

  6. Wenn Sie die Aufgabenverwaltung des Office Managers nicht nutzen, können Sie die Option Tätigkeiten synchronisieren deaktivieren, der Datenabgleich ist dann deutlich schneller.
  7. Klicken Sie auf Starten, um den Datenabgleich auszuführen.

Felder definieren

Sie können hier die Datenbankstruktur des geöffneten Archivs an Ihre individuellen Anforderungen anpassen: neue Attribute hinzufügen, überflüssige löschen, die Bezeichnung ändern und den Eingabestil, z.B. Listenauswahl, festlegen.

Wenn Sie von einer früheren Office Manager-Version (vor 4.0) auf die aktuelle umgestiegen sind, sollten Sie alle nicht benötigten Datenfelder löschen. Dies beschleunigt die Suche und spart Speicher- und Netzwerkressourcen.

Tipp: Erstellen Sie eine Sicherungskopie der Dokumentdatenbank, bevor Sie die Felder ändern.

Wählen Sie bitte im Menü Datei - Datenbank den Eintrag Felder definieren:

Felder definieren

Auf den folgenden Seiten erfahren Sie am Beispiel des Attributs "Kunde", wie ein neues Datenfeld erstellt und im Layout eingefügt wird.

Um ein neues Feld hinzuzufügen, klicken Sie auf den Schalter Neu und geben die gewünschten Daten ein.

Tipp: Nutzen Sie auch die Direkthilfe. Klicken Sie auf Fragezeichen und anschließend auf die Komponente, zu der Sie weitere Informationen benötigen.

Die Registerkarte Feldeigenschaften enthält alle datenbankinternen Parameter des neuen Feldes:

Feldeigenschaften

Interner Name: Name des Datenbankfeldes

Datentyp: Felder für Zeichen, Zahlen, Datum...

Feldgröße: Maximale Zeichenanzahl

 

Auf der Seite Ansicht werden die Parameter für den Office Manager eingegeben:

Ansicht

Bezeichnung: die für den Anwender sichtbare Bezeichnung

Eingabestil: die Art, wie Daten erfasst werden, z.B. Eingabefeld oder Auswahlliste

Klicken Sie auf Übernehmen, um das Feld zu speichern und schließen Sie das Fenster.

Wenn das Archiv auf einem SQL-Server gespeichert ist, können Sie sich mit erweiterten Benutzerrechten an der Datenbank anmelden. Klicken Sie dazu auf den Schalter DB-Login CS.

 

Sofern die Option Eintrag im Menü Suchen markiert war, befindet sich das neue Datenfeld jetzt im Hauptmenü Suchen.

Menü Suchen

Um die Auswahlliste mit Daten zu füllen (in diesem Beispiel "Kunden erfassen"), wählen Sie bitte im Menü Ansicht - Optionen den Befehl Auswahllisten.


Dokumenttabelle anpassen

Neue Felder werden in der Dokumenttabelle als Spalte am rechten Rand eingefügt. Sie können die Tabelle mit der Bildlaufleiste verschieben, um die Spalte sichtbar zu machen. Wichtige Attribute (wie z.B. 'Kunde') sollten aber auf der ersten Tabellenseite sichtbar sein.

Klicken Sie mit der linken Maustaste auf den Tabellenkopf (z.B. Kunde), halten Sie die Maustaste fest und schieben Sie die Spalte an die gewünschte Position.

Spalte verschieben


Layout-Designer

Sie können die Programmoberfläche Ihren individuellen Wünschen anpassen. Wählen Sie dazu im Menü Ansicht - Anpassen - Layouts entwerfen den Eintrag des Layouts, das Sie bearbeiten möchten. Das Fenster Layout-Designer wird geöffnet. Sie können die bestehenden Komponenten mit der Maus verschieben, in Ihrer Größe ändern oder löschen.

Für unser Beispiel klicken Sie bitte im Menü Ansicht - Anpassen - Layouts entwerfen auf den Befehl Eigenschaften-Weitere. Das Dialogfenster 'Datensatz bearbeiten' wird im Layoutdesigner geöffnet:

Layoutdesigner


Datenbankfelder hinzufügen

Klicken Sie auf die Schaltfläche Feldbeschriftung hinzufügen (A) und platzieren Sie das Textfeld auf der Programmoberfläche. Wählen Sie das Datenbankfeld (z.B. Kunde) aus der Liste Datenfeld.

Klicken Sie auf die Schaltfläche Datenfeld hinzufügen (a) und platzieren Sie das Feld rechts neben dem zuvor eingefügten Textfeld. Wählen Sie das Datenbankfeld "Kunde" aus der Liste Datenfeld.

Sie können die Elemente jetzt noch mit der Maus verschieben und in der Größe ändern.

Klicken Sie anschließend auf OK, um das Layout zu speichern.

Komponenten löschen

Markieren Sie das Element mit der Maus und klicken Sie anschließend auf die Schaltfläche Element löschen (Löschen).

Fenstergröße im Layout speichern

Verändern Sie die Größe des Dialogfensters 'Datensatz bearbeiten' einfach mit der Maus. Die Größe wird im Layout gespeichert und beim Öffnen des Archivs entsprechend gesetzt. Mit dem Befehl Optionen - Fenstergröße zurücksetzen kann die Standardgröße wiederhergestellt werden.

Weitere Layoutkomponenten

   A fügt eine Beschriftung mit beliebigem Text ein;
   - Linien und Boxen für die Layoutgestaltung;
   Pinsel Hintergrundgrafik aus einer Datei laden.


* Der Menüpunkt kann vom Administrator gesperrt werden
CS nur in der Client/Server-Version verfügbar