Sprachdateien

Navigation:  Entwicklerhilfe

Sprachdateien

Previous pageReturn to chapter overviewNext page

Teil-Übersetzung der Programmoberfläche

Neben der Auswahl einer Standardsprache (Menü Ansicht | Anpassen | Sprache) erlaubt der Office Manager eine Übersetzung der Menübefehle in beliebige andere Sprachen.

1.Melden Sie sich bitte als Administrator an (Menü Datei | Optionen | Administrator).

2.Öffnen Sie den Makroeditor (Start | Verwenden | Makro | Makro-Editor).

3.Wählen Sie die Skriptsprache "OmAPI".

4.Geben Sie folgenden Quelltext ein (statt "english" verwenden Sie den Namen der Sprache):
{SaveLanguageFile:{Self:CommonFilesPath}english.ini}

5.Klicken Sie bitte auf Start | Makro | Ausführen Run und schließen Sie den Editor.

6.Öffnen Sie die admin.ini und geben Sie Folgendes ein (statt "G:\Office.." verwenden Sie bitte den Dateinamen der  zuvor erzeugten Datei):
[View]
LanguageIniFile=G:\OfficeManager\english.ini

7.Speichern Sie die admin.ini

8.Öffnen Sie die zuvor erstellte Datei "english.ini" im Notepad oder einem anderen Texteditor und übersetzen Sie die gewünschten Texte.

9.Speichern Sie die Datei und starten Sie den Office Manager neu.

Format der Sprachdateien

Es handelt sich um Standard-INI-Dateien:

[Sektion]

Name=Wert

Sie dürfen nur die Werte übersetzen, keinesfalls den Namen oder die Sektion.

Einige Sektion beinhalten mehrere Zeilen mit unterschiedlichen Texten:

[PageControl2]

PCImageListIndexError=Index (%d) muss zwischen 0 und %d liegen

PCNoBaseImages=BaseImages wurde nicht zugewiesen

Übersetzen Sie jeweils den Text hinter dem Gleichheitszeichen. Beachten Sie unbedingt, dass Variablen, wie "%d" oder "%s" erhalten bleiben und in ihrer Reihenfolge nicht geändert werden. Es würde sonst zu Laufzeitfehlern kommen.

 
Die Sektionen der Menübefehle haben folgenden Aufbau:

[FormOmMain.BarManager.MDocNew]

Caption=&Neues Dokument...

Hint=Neues Dokument|Neues Dokument mit Standardfeldwerten erstellen

ShortCut=Strg+N

Caption: der Text des Befehls im Menü. Das Zeichen & kennzeichnet die im Menü unterstrichene Zugriffstaste. Es ist üblich, drei Punkte hinter den Text zu schreiben, wenn der Befehl nicht sofort ausgeführt wird. Wenn sich z. B. ein Dialogfenster öffnet, in welchem man den Befehl abbrechen kann.
 
Menübefehl mit Kurztasten
 

Hint: Hinweis, der an der Maus erscheint, sobald diese über einer Schaltfläche ruht. Wenn gewünscht, kann eine kurze und eine lange Hilfe definiert werden: vor dem | steht die kurze und dahinter die lange Hilfe. Die kurze Version erscheint an der Maus und die lange Version in der Statuszeile. Lassen Sie da Zeichen | einfach weg, wenn Sie nicht zwischen kurzer und langer Version unterscheiden möchten.
 
Kurzhilfe, kurze Version
 
Kurzhilfe, lange Version

 

Shortcut: Angabe einer Kurztaste, wie beispielsweise Strg-N.

Glyph: zusätzlich können Sie die Zeile Glyph=(Dateiname) hinzufügen, um das Symbol durch eine andere Grafik zu ersetzen. Die Grafikdatei muss eine Windows-Bitmap (*.bmp) mit 16x16 Punkten sein.

Siehe auch

Menüband anpassen

Menü Ansicht | Anpassen | Sprache