Office Manager Dokumentenmanagementsystem

Office Manager DMS-Support

Import einer Compass-Archivdatenbank

A. Importieren

  1. Exportieren Sie bitte zuerst eine *.csv-Datei der Archivdatenbank aus dem Compass-Programm.
  2. Ab Office Manager Version 11.0.3.445 können Sie die CSV-Datei direkt importieren. Für ältere DMS-Versionen öffnen Sie diese CSV bitte mit MS Excel und speichern Sie die Daten in einem geeigneten Format, wie z. B. DBase.
  3. Laden Sie die Datei compass.map und speichern Sie diese im Verzeichnis "mappings" unterhalb des Pfades "Gemeinsame Dateien".
  4. Wenn Sie noch kein geeignetes Office Manager-Archiv erstellt haben, dann können Sie die Beispieldatei CAD.omp verwenden.
  5. Starten Sie den Office Manager und öffnen Sie das entsprechende Archiv (z. B. CAD.omp).
  6. Der Import kann einige Zeit in Anspruch nehmen, vor allem, wenn die Volltextindexierung der Zeichnungen aktiviert ist. Bei großen Datenmengen können Sie den Import deutlich beschleunigen, indem Sie die Option Datensätze in Speicher laden auf der Menüseite Ansicht zuvor deaktivieren.
  7. Klicken Sie bitte im Menü Datei | Datenbank | Datenaustausch auf Importieren.
  8. Wählen Sie die zuvor erstellte CSV- oder DBase-Datei als Quelldatei aus.
  9. Klicken Sie auf Map laden und öffnen Sie die Datei "compass.map", um die Felder der Quell- und Zieldatei zuzuordnen.
  10. Prüfen Sie bitte, ob alle relevanten Felder zugeordnet sind.
  11. Klicken Sie auf Importieren, um die Daten einzulesen.

B. Dokumenttypen anpassen

  1. Es ist sinnvoll, jetzt eine Sicherungskopie der CAD.omp zu erstellen.
  2. Blättern Sie bitte in der Dokumenttabelle ganz nach rechts zur Spalte "EXT".
  3. Klicken Sie mit der rechten Maustaste auf die erste Erweiterung (z. B. "dwg") und wählen Sie im lokalen Menü den Befehl Suchen | EXT = dwg. Die Tabelle enthält jetzt nur noch dwg-Dateien.
  4. Ist im Office Manager bereits ein Dokumenttyp für AutoCAD registriert? Falls nicht, dann können Sie einfach eine dwg-Datei vom Explorer per Drag&Drop auf den Office Manager schieben, der Dokumenttyp wird dann automatisch eingerichtet.
  5. Markieren Sie alle Dokumente: die Tabelle anklicken und Bearbeiten | Alles markieren wählen.
  6. Wählen Sie auf der Menüseite Bearbeiten, Gruppe Dokument den Befehl Eigenschaften (bzw. bei einem Office Manager älter 14.0 Ersetzen). Geben Sie im Eingabefeld Dokumenttyp den Typ für dwg-Dateien (z. B. "AutoCAD-Zeichnung") ein.
  7. Klicken Sie auf OK. Die Dokumente werden dem gewählten Dokumenttypen zugeordnet.
  8. Wiederholen Sie die Schritte 1-7 für alle weiteren Dateiendungen: Suche nach der entsprechenden Erweiterung (z. B. "xls"), alle markieren, Bearbeiten | Dokument | Eigenschaften, passenden Dokumenttyp wählen und OK klicken.

C. Dateinamen anpassen

  1. Erstellen Sie eine Sicherungskopie der CAD.omp.
  2. Notieren Sie sich das Verzeichnis, in welchem die Dateien von Compass gespeichert wurden.
  3. Klicken Sie im Office Manager-Menü Start | Suchen auf Felder leeren, und dann auf Suchen, die Tabelle enthält jetzt wieder alle Dokumente.
  4. Melden Sie sich als Office Manager-Administrator an (Menü Ansicht | Optionen | Administrator).
  5. Markieren Sie alle Dokumente.
  6. Wählen Sie Bearbeiten | Dokument | Eigenschaften.
  7. Geben Sie im Eingabefeld Dateiname bitte folgenden Text ein:
    (Dateiverzeichnis)\{Doc:FileName}.{Doc:TMPEXT}
    Ersetzen Sie den Teil "(Dateiverzeichnis)" bitte durch das notierte Compass-Dateiverzeichnis. Achten Sie darauf, dass Sie keine doppelten "\" eingeben.

    Dateinamen ersetzen
     
  8. Mit Klick auf OK werden die Dateinamen angepasst.