Office Manager Dokumentenmanagementsystem

Office Manager DMS-Support

Umzug der Daten auf einen anderen Server

Bei einer Netzwerkinstallation liegen die Daten (Archive, globale Einstellungen und Dokumentdateien) auf einem Server. Das Programm ist in der Regel lokal auf den Arbeitsplätzen installiert.

Um die Daten auf einen neuen Server umzuziehen, werden diese zuerst auf den neuen kopiert. Denken Sie bei der Enterprise-Edition auch an die SQL-Datenbanken. Wenn sich die Pfade ändern, müssen an den Clients die Einstellungen und in den Archiven die Dateipfade angepasst werden.

Servername

Ist es machbar, dass der neue Server den Namen des alten bekommt? Es spart nicht nur im Office Manager einigen Aufwand beim Umzug, wenn die UNC-Pfade zum Server gleichbleiben. Wenn sich die Pfade ändern, wird es vermutlich bei einigen Anwendungen nötig sein, diese anzupassen.

Tipp: Alten Server umbenennen und den neuen mit dem ursprünglichen Namen benennen.

Vorbereitungen

Starten Sie Office Manager DMS an einem Client und wählen Sie den Menübefehl Datei | Information. Auf der Seite Allgemein finden Sie die Angaben zu Gemeinsame Dateien und Dokumentenverzeichnis. Notieren Sie diese beiden Einstellungen. Wenn hier ein UNC-Pfad verwendet wird, beachten Sie den Tipp zum Servernamen.

Standardmäßig wird folgende Pfadstruktur verwendet:
Dateipfade auf Server

Achtung. Ab jetzt dürfen keine Änderungen mehr an den Daten vorgenommen werden. Informieren Sie die Anwender oder führen Sie die folgenden Schritte außerhalb der Arbeitszeit aus. Beenden Sie Office Manager DMS auf allen Arbeitsplätzen.

Daten kopieren

  1. Erstellen Sie auf dem neuen Server die Verzeichnisfreigaben möglichst so, wie auf dem bisherigen Server.
  2. Kopieren Sie die Daten, bei der Standardpfadstruktur ist dies der vollständige Ordner "Office Manager DMS", auf den neuen Server und prüfen Sie die Zugriffsrechte der Office Manager-Anwender in diesen Verzeichnissen.
  3. Wenn Sie den Server auch als SQL-Datenbankserver für die Dokumentenarchive nutzen, dann installieren Sie die SQL-Software auf dem neuen Server und übernehmen Sie die Datenbanken. Je nach SQL-Server können die Datenbankdateien einfach kopiert oder über ein Backup eingespielt werden.

Wenn alle Dateipfade gleichbleiben, sind Sie hier bereits fertig.


Die folgenden Schritte sind nur nötig, wenn der Servername oder ein Freigabename geändert wurde.

Laufwerksbuchstaben

Wenn der Servername geändert wurde und die Pfade mit Laufwerksbuchstaben angegeben sind, dann müssen diese jetzt auf jedem Client angepasst werden, so dass sie auf den neuen Serverpfad verweisen.

SQL-Servername

Anwender der Enterprise-Edition müssen den Namen des neuen SQL-Datenbankservers übernehmen. Der einfachste Weg ist die Änderung direkt in der .omcs-Verknüpfungsdatei:

  1. Öffnen Sie das Verzeichnis "..\Gemeinsame Dateien\Archive" im Windows-Explorer.
  2. Klicken Sie mit der rechten Maustaste auf die erste Datei mit Endung .omcs (Office Manager CS Archiv) und wählen Sie im Popupmenü den Befehl Bearbeiten, um die Datei im Editor zu öffnen.
  3. In der Sektion "[ConnectionParams]", Schlüssel "Server" passen Sie bitte den Servernamen an.
  4. Speichern Sie die Datei und ändern Sie alle weiteren .omcs-Dateien. Ändern Sie nur .omcs-Dateien.

Einstellungen ändern

Folgendes muss an allen Office Manager-Clients durchgeführt werden, weil diese Einstellung in der Registry gespeichert ist:

  1. Starten Sie Office Manager DMS.
  2. Wählen Sie den Menübefehl Datei | Optionen | Einstellungen und wechseln Sie auf die Seite Datenbank. Bei Gemeinsame Dateien geben Sie den neuen Pfad an, beispielsweise "\\sever\freigabe\Office Manager DMS\Gemeinsame Dateien\". Klicken Sie auf den Schalter Automatisch, um die Standard-Datenbanken entsprechend anzupassen. Diese liegen im Unterverzeichnis "...\Gemeinsame Dateien\Archive\".
  3. Klicken Sie auf OK und beenden Sie das Programm.

Nachdem die Änderung an allen Arbeitsplätzen durchgeführt wurde:

  1. Schalten Sie den alten Server ab oder stellen Sie auf andere Weise sicher, dass kein Zugriff mehr auf die alten Pfade besteht.

Folgendes muss nur an einem Client durchgeführt werden, weil die Einstellung im Verzeichnis der gemeinsamen Dateien gespeichert ist:

  1. Starten Sie Office Manager DMS.
  2. Wählen Sie den Menübefehl Datei | Optionen | Einstellungen und wechseln Sie auf die Seite Dokument. Geben Sie als Dokumentenverzeichnis bitte den neuen Pfad an, beispielsweise "\\sever\freigabe\Office Manager DMS\Gemeinsame Dateien\{Self:DocDB,Name}\{Doc:Project}\". Übernehmen Sie auch die Makrovariablen mit den geschweiften Klammern aus der alten Einstellung.

Dateipfade in den Archivdatenbanken anpassen

Folgendes muss nur an einem Client, jedoch in allen Archiven durchgeführt werden:

  1. Klicken Sie im Menü Start auf Felder leeren und anschließend auf Suchen, um alle Dokumente abzurufen, weil die folgende Funktion nur die gesuchten Dokumente ändert.
  2. Wählen Sie den Menübefehl Datei | Datenbank | Anpassen | Dateipfade ändern (siehe auch Hilfe und Support).
  3. Der bestehende Pfadeintrag ist z. B. "\\alterserver\freigabe\Office Manager DMS\Dokumente\".
  4. Bei Ändern in geben Sie den neuen Serverpfad - beispielsweise "\\neuerserver\freigabe\Office Manager DMS\Dokumente\" an.
  5. Als Dateioperation wählen Sie "nicht kopieren". Die Dateien wurden ja bereits kopiert.
  6. Klicken auf Starten und schließen Sie das Dialogfenster, sobald die Funktion abgeschlossen ist.
  7. Wählen Sie den Menübefehl Start | Suchen | Weitere | Datei. Geben Sie "\\alterserver\" ein und bestätigen Sie mit OK. Es sollten jetzt keine Dokumente mehr gefunden werden. Falls doch, dann sind noch Verknüpfungen zum alten Pfad vorhanden.

Anwender der Enterprise-Edition: Wechseln Sie zur Ansicht der archivierten Dokumente (Menü Ansicht | Anzeigen) und wiederholen Sie diese Schritte, um auch die archivierten anzupassen.

Weitere Einstellungen

In Office Manager DMS können Sie viele Konfigurationen vornehmen und sogar Skripte erstellen. Geänderte Pfade müssen überall berücksichtigt werden.

  1. Wählen Sie den Menübefehl Datei | Optionen | Einstellungen und geben Sie links unten im Suchfeld den alten Servernamen ein. Drücken Sie die Eingabetaste und prüfen Sie, ob noch weitere Einstellungen auf alte Pfade verweisen. Beachten Sie insbesondere die Importprofile.
  2. Nutzen Sie Makros oder Skripte, in denen relevante Pfade genutzt werden, dann passen Sie diese an.

Siehe auch

Alle Themen zur Optionsseite "Datenbank"
Wechsel vom Einzelarbeitsplatz zur gemeinsamen Verwendung im Netzwerk